[LUGA] Mit freundlicher Unterstützung von:
Linux New Media AG

Mail Thread Index


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [luga] apache



hallo

> Das Seltsame an der Sache war:  mit der httpd.conf, die ich mir im Laufe
des
> Probierens an meine Bed├╝rfnisse angepasst habe und daher mal
weggespeichert
> habe, habe ich bei der erneuten installation die Original-httpd.conf
> ├╝berschrieben. Und siehe da: es funktioniert!
> Also daran lags anscheinend nicht.
[quote wo zuviel ist]


also ich weiss nicht genau wie jetzt deine konfiguration aussieht aber das
problem sieht wirklich nach einem permission problem aus (fehlermeldung)
die rechte zu dem htdocs verzeichnis muessen o+x sein und die seiten im
htdocs o+r
ausserdem muss (wenn du eine standardkonfiguration hernimmst die
directory-direktiven verendet)
es eine directory-direktive geben fuer das htdocs verzeichnis.
z.B (ausschnitt aus meiner, muss nicht genau gleich sein):

<Directory "/usr/local/httpd/vhosts/domain/htdocs">
  Options +FollowSymLinks +IncludesNOEXEC
  AllowOverride All
  Order allow,deny
  Allow from all
</Directory>

das verzeichnis stimmt eher nicht mit deinem zusammen, musst eben das
richtige verzeichnis einsetzen, der rest sollte so auch funktionieren, am
besten du siehst dir die directory direktive auf www.apache.org an.

wenns danach nicht funktioniert ists wohl doch was anderes.

es kann auch sein dass du keine index.html in dem verzeichnis hast! wenn du
indexes naemlich ausgeschaltet hast fuer dieses verzeichnis und es keine
index.html gibt (soweit index.html als DirectoryIndex definiert ist)
kriegst du genau die fehlermeldung.

pfiatenk
  peter




powered by LINUX the choice of a gnu generation
linux user group austria;
Suche
Suche
Letzte Änderung:
webmaster@luga.at
September 2010