[LUGA] Mit freundlicher Unterstützung von:
OCG

Mail Thread Index


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[luga] Wireless Bridge mit OpenWRT



Hallo,

ich hab heute eine WLAN-Bridge mit zwei N750 (also TL-WDR4300) gebastelt.

Das Environment in dem das ganze laufen soll sieht wie folgt aus:

Büro:
ca 10 Windows-7 PC's an einem SBS-2012 (der auch DHCP spielt)
1 Ubuntu File-Server
Internet-Router (TBD...)
VOIP-Telefonanlage mit intern VOIP und (vorerst) extern ISDN.

WDR4300-AP
 |  |
1x 2.4GHz Bridge, 1x 5GHz Bridge
 |  |
WDS4300-CL

Werkstatt:
3 Windows-7 PC's (am selben SBS)
Steinzeit-PC mit Lynx-OS (Rechner für CNC)

Die Telefone sollen entweder ans LAN gesteckt oder via WLAN eingebunden
werden. (Telefon muss nicht unterbrechnungsfrei sein wenn man zum anderen
Standort geht)

Beide Standorte sind ca. 50M voneinander entfernt und haben
Sichtverbindung (über die Straße)

Aktuell sind keine WLan-Netze in Reichweite weder am 2.5 noch am 5GHz Band
(aber das muss ja nicht so bleiben...)

Die Router LAN-Interfaces selbst hab ich auf DHCP-Client gestellt (der
eine bekommt also die IP direkt vom DHCP, der andere über die WLAN-Bridge
vom selben DHCP)

Firmware ist openwrt-ar71xx-generic-tl-wdr4300-v1-jffs2-factory.bin

---

/etc/config/wireless am AP schaut wie folgt aus:
config wifi-device 'radio0'
	option type 'mac80211'
	option macaddr '...83:05'
	option hwmode '11ng'
	option htmode 'HT20'
	list ht_capab 'LDPC'
	list ht_capab 'SHORT-GI-20'
	list ht_capab 'SHORT-GI-40'
	list ht_capab 'TX-STBC'
	list ht_capab 'RX-STBC1'
	list ht_capab 'DSSS_CCK-40'
	option channel 'auto'
	option country 'AT'
	option txpower '20'

config wifi-iface
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'myBridge'
	option wds '1'
	option encryption 'psk2+tkip+ccmp'
	option key '... top secret ...'
	option macfilter 'allow'
	list maclist '...82:AB'

config wifi-device 'radio1'
	option type 'mac80211'
	option macaddr '...83:06'
	option hwmode '11na'
	option htmode 'HT20'
	list ht_capab 'LDPC'
	list ht_capab 'SHORT-GI-20'
	list ht_capab 'SHORT-GI-40'
	list ht_capab 'TX-STBC'
	list ht_capab 'RX-STBC1'
	list ht_capab 'DSSS_CCK-40'
	option txpower '17'
	option country 'AT'
	option channel 'auto'

config wifi-iface
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'myBridge'
	option encryption 'psk2+tkip+ccmp'
	option key '... top secret ...'
	option wds '1'
	option macfilter 'allow'
	list maclist '...82:AC'

und am client gleich bis auf:

config wifi-iface
	option device 'radio0'
	...
	option mode 'sta'
	option network 'lan'
	option bssid '...83:05'

config wifi-iface
	option device 'radio1'
	...
	option mode 'sta'
	option network 'lan'
	option bssid '...83:06'

Somit sind die SID's mal nicht sichtbar, der Traffic wird mit WPA2
verschlüsselt und der AP akzeptiert nur seinen Client.

Nachdem ich alle vier Interfaces aufgedreht hatte war mal nach wenigen
Sekunden komplette Funkstille (auch in meinemn LAN)

Nach kurzem Googlen und und anpassen der /etc/config/network:

config interface 'lan'
	option ifname 'eth0.1'
	option type 'bridge'
	option stp 1    <== Das ist nötig!!!

ist aber alles brav gelaufen, Jetzt kann ich alternativ den 2GHz oder den
5GHz Clannel deaktivieren oder auch beide aktiv lassen und es geht kein
Ping verloren.

Nur: Wenn beide Bridges up sind geht der Traffic über nur _einen_
channel.. welcher ist zufällig und ich hab auch keine Möglichkeit gefunden
zB. dem 5GHz Channel Priorität zu geben. Spanning-Tree Costs kann ich auch
keine definieren da ich auf jeder Seite ja nur eine Bridge hab (Kosten
gehen ja nur auf die Bridge aber nicht auf die Interfaces?).

Ich bin mir auch nicht sicher wie zuverlässig die Umschaltung
funktionieren wird wenn ein Channel mal gestört wird. (Mama kommt heim,
dreht das Babyphone auf und schaut über die Funk-TV-Bridge fern: 2.4GHz
Band ausgelastet :-() Prinzipiell wäre es mir eingentlich lieber wenn
beide Channels gebündelt werden - und dann eventuell je nach vorhandener
Bandbreite die Last darauf verteilt wird.

Nur geht wie das?

Und geht das mit OpenWRT Mitteln (und vertretbaren Aufwand) überhaupt?

... wie stehen die Chancen dass damit VOIP-Telefonie problemlos
funktioniert? Aktuell braucht ein Ping ca. 1ms länger wenn es über die
WLAN-Bridge geht (und die Router unmittelbar nebeneinander stehen)

Bzw. hat wer für die hier gezeigte Konfiguration weitere Tipps was ich
noch ein-/umstellen sollte?

lg Robert




powered by LINUX the choice of a gnu generation
linux user group austria;
Suche
Suche
Letzte Änderung:
webmaster@luga.at
November 2013