[LUGA] Mit freundlicher Unterstützung von:
init.at

Mail Thread Index


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[luga] Apache2



Nochmals gesendet, aber diesmal mit statischem Zeilenumbruch.

Liebe Clubmitglieder,




ich bitte dringend um Eure Hilfe!



Auf meinem Debian 8.6 (oder 8.7 ?) habe ich den Webserver   Apache2   installiert. 
Grund: bevor HTML - Scripte oder ähnliches auf den PC losgelassen werden, 
werden diese von   Apache2   auf Sicherheit geprüft und gegebenenfalls blockiert.



Jetzt stehe ich vor folgendem Problem: 

Normale Internetanwendungen funktionieren nach wie vor 
(Internet, Email, Browser im Docker) .


Paketverwaltungen sind nicht mehr zu gebrauchen - funktioniert nicht mehr:
     apt-get upgrade, apt-get purge (ich kann apache2 nicht mehr deinstallieren), 
     Befehle mit "dpkg", Synaptic - Paketverwaltung 
           (entspricht Ubuntu-Softwarecenter oder Apper)

Es kommt die Meldung: 
"Der dpkg-Prozess wurde unterbrochen; 
Sie müssen manuell »dpkg --configure -a« ausführen, um das Problem zu beheben."


Wenn ich dies tue, dann kommt:
"dpkg --configure -a
linux-image-3.16.0-4-amd64 (3.16.43-2+deb8u5) wird eingerichtet ...
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-3.16.0-4-amd64"
Der Computer bleibt bei dieser Meldung stecken. 
Das eigentliche Problem wird dadurch nicht behoben.

Folgende Befehle funktionieren trotzdem: apt-get update, apt-get clean
Innerhalb Docker funktioniert nach wie vor alles.



In der Datei   /etc/apache2/ports.conf   habe ich die Ports verändert.
     1.) Damit apt und dpkg ihre alten Ports wieder zurück bekommen.
     2.) Firefox wird in seiner Konfiguration an   Apache2   angehängt.
         (zumindest als vorläufige Lösung)

Der GESAMTE Text in   /etc/apache2/ports.conf   sieht dann so aus:

# If you just change the port or add more ports here, you will likely also
# have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default.conf
# das habe ich mit Port 107 gemacht
# für den Port 1194 wird dort keine Möglichkeit geboten!

# in   /etc/services   enthalten	# original	# nicht in /etc/services enthalten
								
Listen 107				# 80		81	# http

<IfModule ssl_module>
	Listen 1194			# 443		446	# https
</IfModule>

<IfModule mod_gnutls.c>
	Listen 1194			# 443		446	# https

</IfModule>

# die oben angeführten Ports sind in   /etc/services   definiert, 
# werden aber nicht verwendet 
# 107 - Telnet, 1194 - openvpn; beide sind nicht installiert

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet
# ich kann vim nicht installieren

--- end of file ---

Obige Datei wurde mit leafpad konfiguriert.


Vermutlich erwartet man von mir, 
dass ich mich zunächst selbst nach einer Lösung umsehe. 
Das habe ich auch getan! 
Aber angesichts der Dringlichkeit von "upgrade" 
bleibt mir aber leider nicht viel Zeit!


Nun bitte ich Euch um Eure geschätzte Hilfe! 
Ich freue mich über jede Antwort!


freundliche Grüße
Peter




powered by LINUX the choice of a gnu generation
linux user group austria;
Suche
Suche
Letzte Änderung:
webmaster@luga.at
September 2017